MaxxAir fan green LED and audible alarm

Old Crow

Searching....
Joined
Jan 10, 2015
Messages
1,066
Location
South Central PA
This evening my wife turned on our MaxxAir fan and it did something I’ve not seen before. A green LED began flashing and there was an audible alarm…an urgent beeping sound.

I tried pressing fan buttons to stop it but no luck. Then I noticed the blade was hitting something and couldn’t turn. It looked like a small rock.

I removed the screen as quickly as I could but before I could get it off the alarm stopped and the LED changed from flashing green to solid green.

The small rock turned out to be a largish chunk of mud-wasp nest.

I tried holding down the power button hoping for a reset but no luck. We happen to have cell signal tonight so I was able to learn that it can be reset by disconnecting power from the fan, then reconnecting it.

That worked and there appears to be no damage done.

I can’t see any evidence of a mud-wasp nest anywhere around the fan so that’s quite a mystery. When I get home I’ll look more closely from the outside.

My fan is the MaxxFan Deluxe 5100k model.
 
It's possible that the problem could be more than a mud dauber. Basically, the MaxAir fans are designed to run on a pretty narrow band of 12-13 volts. If you have solar (and most of us do), that could easily put out over 13 volts which triggers that alarm in some fans and can fry the mother board in others. I bought a voltage regulator on Amazon and installed it between the wires bringing power in and the fan itself and that solved the problem. I actually had Maxxair replace 2 fans under warranty before the problem was figured out.

MaxxAir is aware of this problem and says they will fix it but as far as I know, it hasn't but maybe someone else knows if they have.
 
Thanks for the info, Kevin.

In this case, I’m pretty sure it was the chunk of dauber nest. We’ve been using the fan several times a day for the past two months with no issues. And I saw the fan reacting to the chunk of mud between one of the fan blades and the screen. It would push a little and stop then try pushing again all the while sounding the alarm and flashing the LED. Then it went silent and quit trying and left the LED solid green.

It occurs to me that a wasp may have made the nest as my rig sat in the driveway with the vent open earlier this summer. I normally travel with the vent lid down but yesterday I had it up. A different pattern of jarring the vent may have broken loose the chunk of mud.

You make a good point about the voltage regulator. I don’t have solar but my charger sometimes charges as high as 15 volts. I need to look into that.
 
I've found a few nuanuces on the maxxair fan that I wish they'd rethink. Don't get me wrong, I'd take this fan over fantastic fan any day (customer service at fantastic is terrible, etc.).

Here's a few things I've learned, found out, etc.

The rain sensor only works if you turn the fan on. You can't manually open the fan lid. I suspect it must be something to do with current draw but that has to be so small I'm not sure what else the reasoning could be.

Assuming you want the rain sensor to work, if you open the lid with the remote, it opens completely (you can just use the power button). You can't (at least I haven't figured out how) to stop the lid partially open with the fan blades off. You have to let it open all the way and then manually close it to the height you want. Now the rain sensor is activated and if you want to have the vent open w/o having the fan blowing, you have to use the speed control to turn the fan off/down. On the fantastic fan, you just open the lid and the rain sensor is "on".

Minor issues. I still perfer the maxxfan!
 
Back
Top Bottom