Cassette Toilet Issue

BrianG

Senior Member
Joined
Jan 25, 2015
Messages
196
Location
Northern Nevada
I have a 2015 Hawk with the Thetford cassette toilet, manual flush. Last month I put the camper on the truck and the first time I used the toilet, it made a sound like something broke. Since, it really doesn't flush with any force and the up down movement of the flush handle is overly easy, little resistance up or down.

So, obviously something is broken. I've watched a video on how to take the manual flush system apart, but don't want to attempt it, until I have a spare pump in hand.

The part number is Thetford 2373962, but this part is nowhere to be found online in the USA! Today sent out emails to Thetford USA, FWC and American RV, probably won't hear anything until next week.

Does anyone have any info relating to this problem?

Thanks
 
I have found that Thetford is problematic for finding parts in North America, even at their U.S. parts location.

I have the electric flush and have found Thetford parts readily available in the U.K.
You've probably saw the same thing when you searched online.
I believe I used LeisureShopDirect, here's the web page, scroll down the left side menu to "Water" then you'll see "Caravan Toilets" and the types of toilets are under that. See if you can find what you are looking for there.
Shipping cost wasn't that bad and the part I wanted arrived in under two weeks.
 
Thanks, I found the overseas options, it's nice to hear it's a good possibility. I'll wait for replies from the sources I mentioned above before ordering from overseas sources. I'll also post the replies from Thetford USA, FWC and American RV. American RV was excellent to deal with last year when they ordered an additional tray for my Dometic refer.
 
Received two C-200 CW Manual Flush Pumps today from the UK. Only took a week and a half, cost for two + shipping $96.00. Purchased from:

www.caratech.co.uk

Thetford doesn't sell this model in the USA, so you have to go to the UK for parts. Caratech does have an eBay site, but for overseas shipping you must go to their website above. Paid with Paypal, very easy.

Pumps came with extra screws, sealing tape and instructions. Just make sure you connect the hose with the unit outside the enclosure, you have a much better grip, I removed the part where the hose attaches to make sure I didn't damage anything.

As for the old pump, I didn't remove it until I got the new ones. As mentioned in online forums, the bottom had come loose due to a broken catch. I think this is fixable, so now I have lots of extra parts. Pump works fine when I hold the bottom on.

The electric flush version of this toilet, C-200 CWE is sold in the USA, so that's the version you want in your FWC.

Any questions let me know.
 
I need to disassemble the pump handle assembly on my toilet in order to inspect the LED fill light. However, I can't find any instructions, and regardless of how hard I pry, none of the applicable parts want to pop off (the top to the flush handle or the flush assembly trim piece attached to the toilet housing with two screws). I don't want to break anything. Do you have any pointers on disassembling?
 
Wandern, just noticed your reply to this thread. It was quite awhile ago that disassembled my toilet, good news it’s worked great since. I had no trouble but the top cover, if I remember, is caulked in place, so you must carefully work it off. This is why I stopped disassembly until I had new parts.

I purchased two assemblies from the UK because the shipping was the same. Good Luck
 
BrianG said:
Wandern, just noticed your reply to this thread. It was quite awhile ago that disassembled my toilet, good news it’s worked great since. I had no trouble but the top cover, if I remember, is caulked in place, so you must carefully work it off. This is why I stopped disassembly until I had new parts.

I purchased two assemblies from the UK because the shipping was the same. Good Luck
Thanks, Brian. I eventually realized that the cover was being held in place by butyl putty. I raised the temperature in the camper to 90 degrees for a few hours and was then able to easily prise off the cover.

Thanks for the comment...
 
FYI. Replaced pump on Thetford C200 which is installed on my 2013 Fleet. Parts are hard to find in the U.S. other than EBay which are expensive. Found parts on Amazon Europe and shipping via prime was free. Easy repair.


https://a.co/d/6yRiJsX
 

Latest posts

Back
Top Bottom