Heater and Voltage

Aug 3, 2021
Raleigh, NC
I have a Swift Shell with the furnace that I picked up in January and finally got the chance to use it last weekend. I ran into an issue when what was supposed to be a mid 40 degree night turned to high 20's, My furnace wouldn't light, which it did when I tried it in the driveway after bringing the camper home.

What I'm finding is if the voltage is 12.8v or lower the furnace won't light (I haven't seen it at 12.9, but it doesn't light at 12.8 and but does at 13.0). The fan comes on and clicks, every once and a while you can hear the gas ignite then immediately shut off. If the voltage is 13v or high the furnace just starts like it should.

Before I go through the FWC furnace troubleshooting video, has anyone see this exact behavior before and have what fixed yours? I'm assuming either a sail switch being weird and not beeing triggered when the fan is moving fast enough, or maybe the circuit board that controls things (I've seen a weird number of odd issues where that was the problem). I'm assuming since it turns on correctly at voltage the thermostat probably isn't the issue.

My expectations are that fan speed issues due to voltage should start to happen around 12.3-4 volts since it's getting pretty low at that point. Let me know if that assumption is off with it.

Thanks for sending those and I did find those while searching before, but nothing totally matched up exactly to what I was seeing.

I think the thing the internet said to do day 1 is something I should have done on day 1. I removed the small piece of ducting and the furnace has worked perfectly down to 12.4v and 29 degree weather this morning. I knew about everyone doing the duct delete and how it's the first thing you should do. However I was like eh I'll use it a few times to see if it's ok. Everything I read about that duct being an issue was in relation to high altitude or extreme cold (single digit Fahrenheit), so I figured since I'm in the South East in March neither of those would be an issue, welp I might have been wrong on that.

Fingers crossed that was 100% the issue.
Are you checking the voltage at the furnace or at the battery? Could it be voltage drop?
Bigfoot Dave
Bigfoot Dave said:
Are you checking the voltage at the furnace or at the battery? Could it be voltage drop?
Bigfoot Dave
I'm just using the display on the Victron Overland MPPT solar info screen. I have that changed to read the battery voltage since it's a bit more accurate than the voltage read out from the one with the usb/12v plug. I haven't put a voltmeter to to the battery, but feel like that read out is good enough to give me an idea of the voltage status. Basically is the battery full, midway discharged, or low. Also it made for a common method to view battery status since that's what I was using when I was camping and it didn't work. I'm thinking if that was saying 13v+ and the other read out was around 13v+, the actual voltage wouldn't be at like 12.2v or something. However I could be way way off on using that as the point of measure for seeing if it was related to high, med, low voltage status.
I believe what Bigfoot Dave is implying, that the voltage at the battery or the furnace can be different because of voltage drop across the supply leads to the furnace. To small or long supply leads or a bad connection can drop voltage to the furnace. That’s why it is kind of important to measure the voltage at the furnace. To see if it is a voltage problem.
My camper is quite a bit older, but I was experiencing the same thing. Swapped out a new sail switch and no change. If there was a charging source the heater would work fine. I finally gave up and added a small piece of tape to the sail switch and its been 100% problem free.
Top Bottom